Technology is great and technology sucks. It’s true that it’s the best of times and the worst of times. Technology is great when it works, but it’s terrible (and often unfixable) when it doesn’t.

This may be a farewell to my Fitbit Charge 4, and a warning to fitness tracker developers out there. Rigorously ensure sure it works or people will not just abandon your product, they’ll abandon your platform.


I thought the Fitbit Charge 4 was my answer to getting rid of my old Garmin. My handheld Garmin eTrex started turning off randomly. But when it worked, it worked – probably because it had one job: record GPS tracks.

I had some issues with my Fitbit losing GPS signal, but I thought they were fixed. But they’re not…

I brought my new kayak to Lake Minnetonka and planned to paddle around Big Island. I’ve tried both GPS settings on the Fitbit Charge 4: Built-in GPS and Dynamic. Dynamic will use your phone if it’s nearby, then fallback to built-in. That day, I had the watch set to “built-in GPS.” I went down to the dock and hit start on my Fitbit. It was still trying to get GPS signal by the time I had my boat ready.

I went out on the water thinking the clear view of the sky would help it quickly lock on to GPS signal. I sat there for several minutes, then decided to switch to Dynamic since I did have my phone in the boat. After several more minutes of no GPS signal, I got my phone out. Opening the Fitbit app on my phone immediately established GPS signal. So I got underway.

Then as I rounded the first corner of the island, the watch vibrated. The screen displayed “Cannot establish a GPS Connection. Turning GPS off” 😡

You can see how far I had gone when the Fitbit gave up, it’s the untracked distance between the start and finish point.

Elapsed Time Moving Time Distance Average Speed Max Speed Elevation Gain
The Strava app proved to also have (different) problems than my Fitbit

Strava App

I already had my phone out of my dry bag, which I didn’t want to do, because I’m in the water 🌊 But here I was, so I fired up the Strava app and hit record. Before got into the channel I got out my fish finder just to see if there were any lively spots that we should hit later on the pontoon. 🎣

But while getting out the fish finder, the Strava app decided to engage “auto-pause.” Auto pause seems like a good idea until it doesn’t auto un-pause. I was on the other side of the island before I noticed it was paused. While on the water I had to figure out how to unpause. I went into the settings and turned off auto-pause. Auto Pause settings are accessible by using the gear icon from the record activity screen. Not the main screen gear icon. ⚙️

Strava Auto-Pause Settings

But it was still paused! The only way to forcibly un-pause the activity was to click “Finish” which brought me to a confirmation screen, then I was able to choose “Resume” which un-paused the activity. It’s not clear that there will be a confirmation after clicking finish, so I’m showing an example here:

Strava Finish Confirmation (use to un-pause)

You can see the line that goes through the island on my activity. Clearly I didn’t do that, but that’s how it will be recorded “because technology.” Now imagine if this was your first experience with either of these devices and services. I wanted to throw both my watch and phone in the lake! 💦

But since I’m a glutton for punishment, I’ll be trying something else to replace these failed experiments. Currently looking at the Amazfit GTR series watches because battery life looks good. Recommendations welcome – please comment with your suggestions!

One thought on “The State of Fitness Trackers

  1. Pingback: Fitness Watch Take 2: Amazfit GTR-3 - Justin Foell

Leave a Reply