I like this Microsoft “Mobile Mouse” 3600. It connects to my laptop via bluetooth so there’s no need to add a dongle.

It works with Linux but it’s a bit finicky. In this post I’m addressing Ubuntu 16.04 LTS. This might seem like moot point because 18.04 LTS is literally right around the corner. However, there a chance it’s meticulous connection procedure will still need to be followed. So here’s how to consistently get it to connect to your computer.

I’ve highlighted all the commands you’ll need to type in bold. The other text is the output you’ll be seeing. The device ID will be different for your 3600 mouse, and it will be different every time you try to pair it. Just be careful to copy and paste off of your screen and not mine 😉

Put your mouse into pairing mode by holding the bottom button down for more than 5 seconds. Then launch the bluetooth control tool from the terminal, and start a scan. Note the ID of BluetoothMouse3600, you’ll use it for the commands pair, trust, and connect.

$ sudo bluetoothctl
[bluetooth]# scan on
Discovery started
[CHG] Controller 28:B2:BD:5A:33:17 Discovering: yes
...
[NEW] Device EF:E5:F1:8D:EA:24 BluetoothMouse3600
[CHG] Device EF:E5:F1:8D:EA:24 RSSI: -42
[bluetooth]# pair EF:E5:F1:8D:EA:24
Attempting to pair with EF:E5:F1:8D:EA:24
...
[CHG] Device EF:E5:F1:8D:EA:24 Paired: yes
Pairing successful
[BluetoothMouse3600]# trust EF:E5:F1:8D:EA:24
[CHG] Device EF:E5:F1:8D:EA:24 Trusted: yes
Changing EF:E5:F1:8D:EA:24 trust succeeded
[BluetoothMouse3600]# connect EF:E5:F1:8D:EA:24
Attempting to connect to EF:E5:F1:8D:EA:24
Connection successful

Sweet we’re connected! But your mouse probably won’t (yet) work. We need to disconnect first (I’ll explain why in a bit).

[BluetoothMouse3600]# disconnect EF:E5:F1:8D:EA:24
Attempting to disconnect from EF:E5:F1:8D:EA:24
Successful disconnected
[CHG] Device EF:E5:F1:8D:EA:24 Connected: no

Why am I doing this again?!?

I’m not exactly sure why this needs to be done twice, but somewhere along the way I believe I saw some bluetooth debugging information show that the first device is for BLE (bluetooth low energy) and the second is the actual HID (human interface device). Comment if you can confirm or deny, but for now, let’s keep truckin’…

Put the mouse into pairing mode again. Then pair/trust/connect again . You may notice the number in the 4th section of the device ID is one number higher than it was when we first paired.

[NEW] Device EF:E5:F1:8E:EA:24 BluetoothMouse3600
[bluetooth]# pair EF:E5:F1:8E:EA:24
Attempting to pair with EF:E5:F1:8E:EA:24
[CHG] Device EF:E5:F1:8E:EA:24 Connected: yes
[BluetoothMouse3600]# trust EF:E5:F1:8E:EA:24
[CHG] Device EF:E5:F1:8E:EA:24 Trusted: yes
Changing EF:E5:F1:8E:EA:24 trust succeeded
...
Pairing successful
[CHG] Device EF:E5:F1:8E:EA:24 Modalias: usb:v045Ep0916d0100
[BluetoothMouse3600]# connect EF:E5:F1:8E:EA:24
Attempting to connect to EF:E5:F1:8E:EA:24
Connection successful

Now your mouse should work!

If you find it not reconnecting on occasion, turning the mouse off/on with a quick press of the bottom button sometimes does the trick. Otherwise, remove both of the bluetooth devices that are paired and start from the top. I’ve done this several times and this is the only consistent way I’ve been able to get it working again.

2 thoughts on “Microsoft Mouse 3600 and Ubuntu 16.04 LTS

  1. absolutely unbelivable. I have been messing with this for half a year. There is no reason to this. It just sometimes works, sometimes doesn’t. Goddamn linux. And now when googling again, i see that in Ubuntu 18 people STILL mess around with this stuff. It never ends.
    Anyway, thanks for showing bluetoothctl commands. Randomly pairing/unpairing eventually worked

    Reply
    • Yeah, it’s frustrating. I’m not sure who to blame on this one, but the 3600 had some odd behaviors in OSX as well. Hopefully this helps someone besides myself.

      Reply

Leave a Reply